Java Mailing List Archive

http://www.junlu.com/

Home » JDOM Projects »

[jdom-interest] required dependencies

Steffen Pingel

2008-03-04

Replies: Find Java Web Hosting

Author LoginPost Reply
Hi,

I am trying to determine the minimal dependencies for the Eclipse Orbit JDOM
1.0 bundle [1]. The bundle currently specifies Xerces as a mandatory
dependency. My understanding is that with Java 1.4 or higher this dependency
is optional and JDOM will use the built-in XML parser of the JRE if Xerces is
not available.

Is the assumption correct that JDOM will work without any additional
dependencies if running with Java 1.4 or higher?

Thanks.
Steffen


[1] 221047: make Xerces dependency in org.jdom bundle optional
https://bugs.eclipse.org/bugs/show_bug.cgi?id=221047

--
Steffen Pingel - steffenp@(protected)
_______________________________________________
To control your jdom-interest membership:
http://www.jdom.org/mailman/options/jdom-interest/youraddr@(protected)
©2008 junlu.com - Jax Systems, LLC, U.S.A.